¡Ya está disponible el polémico WordPress 5.0! ¿Cuándo actualizar?

¡Ya está disponible el polémico WordPress 5.0! ¿Cuándo actualizar?

Si te gusta WordPress, si lo usas y tienes alguna web con este CMS, seguro que siempre has confiado mucho en sus actualizaciones. Y hasta ahora siempre han sido muy estables y era muy recomendable actualizar cuanto antes cualquier nueva versión de WordPress. Por supuesto siempre puede haber algún plugin incompatible, algún theme incompatible, pero hasta ahora todas las actualizaciones de WordPress han sido muy fiable. Pues bien, con la nueva versión 5.0 la comunidad de WordPress ha puesto el grito en el cielo al descubrir importantes bugs en muchos plugins muy utilizados que hacen que esta nueva versión publicada no sea del todo estable.

Se está tendiendo a decir que no actualices WordPress a su versión 5.0 y los usuarios tienen el miedo en el cuerpo. Por una parte, siempre se ha dicho y es cierto, que cuando hay actualizaciones de WordPress hay que actualizar porque tienen corregidas vulnerabilidades, y por seguridad, siempre es recomendable actualizar cuanto antes. Pero en este caso, al menos por lo que WordPress publica en https://wordpress.org/support/wordpress-version/version-5-0/ no hay mejoras de seguridad y no es uno de los objetivos de esta nueva versión. Por lo que por ese aspecto, no corre ninguna prisa actualizar a la versión 5.0

Tienes muchos más detalles en inglés de todo lo nuevo que trae WordPress 5.0 en su blog oficial: https://wordpress.org/news/2018/12/bebo/

Pero de lo que mucha gente habla es del nuevo editor llamado Gutenberg basado en bloques:

  • Más flexibilidad a la hora de mostrar el contenido.
  • Puedes incrustar automáticamente cualquier tipo de contenido.
  • El contenido se divide en bloques haciendo muy fácil modificar cualquier cosa.
  • Hay una gran cantidad de bloques por defecto disponibles: párrafo, encabezado, texto preformateado, cita, imagen, galería, imagen de portada, video, audio, columnas con bloques anidados, archivos, código, etc.

Todo esto con la gran ventaja de que los bloques son reutilizables.

Para los que prefieran el editor clásico, estará disponible hasta 2021. Y algunos valientes que ya se han decidido a pasar a WordPress 5.0 lo han hecho manteniendo el editor clásico por los problemas que está dando el nuevo editor.

Concluyendo: si tienes una web con WordPress y para ti es importante la estabilidad, ya sea porque tienes una tienda o que tu negocio depende del tráfico de tu web. Te recomendamos no actualizar. Se comenta que en enero habrá novedades, y parece una mejor fecha para actualizar o para esperar correcciones de esta nueva versión.

Por otro lado, si usas plugins de constructores tipo “Page Builder“, es muy probable que todas estas páginas se vean afectadas. Por lo que igualmente si es tu caso, mejor esperar.

Si usas el plugin para campos personalizados “Advanced Custom Fields“, los desarrolladores del plugin ya han comentado que están teniendo incompatibilidades con el nuevo editor, y están trabajando en ellos. Pero igualmente si usas este plugin, no te funcionará.

Si para las traducciones usas el plugin “WPML”, más de lo mismo. Los desarrolladores de WPML comentan que de momento su plugin no es compatible, así que tampoco puedes actualizar aún.

Por todo esto, y probablemente por muchas cosas más que aún están por salir, te recomendamos esperar, paciencia y no dudes en consultarnos cualquier inquietud ¡Para eso estamos!

Entradas relacionadas

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *